September 26, 2022, 06:28:15 AM

News:

IonicWind Snippit Manager 2.xx Released!  Install it on a memory stick and take it with you!  With or without IWBasic!


Aurora update Alpha 3 Rev 4

Started by Ionic Wind Support Team, May 31, 2006, 01:06:27 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Ionic Wind Support Team

May 31, 2006, 01:06:27 AM Last Edit: May 31, 2006, 01:08:50 AM by Ionic Wizard
The Aurora compiler has just been updated.  To get the update redownload from the link provided when purchasing.

Changes/Additions
-------------------------
- Class method implimentation can now be written within the class definition.
- A bug in include file processing was fixed.
- C2DSurface::GetSurfacePointer and C2DSurface::GetSurfacePitch methods added.
- A few problems with auto indentation were addressed.
- The Subs/Methods pulldown was recognizing non methods.  Fixed.
- A DECLARE EXTERN is now ignored if the subroutine appears in the same source file.

More information about class methods within class definitions.  A class method is normally defined outside of the class definition using the :: operator.  Beginning with this revision you can create the method directly within the definition like so:


class test
{
uint m_uData;
float m_flData;
point pt;
int m_nData;
declare virtual blah2(),int {return 0;}
declare test()
{
m_nData = 99;
m_flData = 1.0f;
m_uData = 0xFFFFu;
}
declare GetIt(),int
{
return m_nData + 1;
}
}


This is useful for creating accessor methods (get/set) and smaller methods that don't warrant separating the implimentation. 

If your going to use methods embedded in the class definition you should be aware of the following:

#1.  Methods defined in an include file will increase compile time and make the resultant object files larger.  It will have no effect on the final size of the executable though. 

#2.  Member variables should be defined ahead of any embedded methods that reference them.  Or you should at the minimum use #autodefine "OFF" to report accessing of member variables before they are defined.

-------------------
The demo version has also been updated.

Have fun.

Paul.
Ionic Wind Support Team

Bruce Peaslee

Thanks, Paul. This language is starting to hum.
Bruce Peaslee
"Born too loose."
iTired (There's a nap for that.)
Well, I headed for Las Vegas
Only made it out to Needles

Ionic Wind Support Team

Thanks.

The source library has been updated for this release.
Ionic Wind Support Team

Vikki

Hi Paul,

Should the About Box be reporting Alpha 3? I uninstalled and installed the latest version but it reports Alpha 2. Just want to be sure I'm working from the most current version.  ;)

Ionic Wind Support Team

Yes it should. Do you have two installations perhaps?  Had it running when you uninstalled?  The about box also shows the current compiler (acparse) version which is 1.0.0.304

Ionic Wind Support Team

Vikki

Hrm, ok, I'll unistall and try again.  ;D Thanks!

Ionic Wind Support Team

And the other thing I have seen...two different downloads.  Perhaps you have an older .zip hanging around. 
Ionic Wind Support Team

Vikki

That's what I thought I did but I tried it a couple of times. I do keep the old zips in different folders from habit. Just like with the help file, I had to uncheck the security warning and do it again. That solved it. Not sure what I've got set up in this computer, it's new, but every time I open and install something that isn't signed or whatever I get that security warning. If I uncheck the Alway check box then things do what they are supposed to. Anywho, I'll do a little research into that after I play abit. Thanks!  8)

Ionic Wind Support Team

Probably becuase your using IE to download it with. 
Ionic Wind Support Team

Vikki

Yes, you are correct. I'll use something else from now on then if IE is gonna do that.  ;)

Ionic Wind Support Team

It is Microsofts solution to security.  Just block everything downloaded from running if it isn't signed.  Then if the user unblocks it they don't have any resposibility.  Much cheaper for them then actually fixing the holes ;)
Ionic Wind Support Team

Rock Ridge Farm (Larry)

I use firefox and have no issues. The only problem I ever had was I had a second install in a different location
that was being picked up - made for a fun afternoon - I deleted all Aurora installs and it worked fine after that.