September 26, 2022, 01:08:13 AM

News:

Own IWBasic 2.x ? -----> Get your free upgrade to 3.x now.........


IDE behaving a little strange.

Started by Egil, August 15, 2016, 05:02:05 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Egil

August 15, 2016, 05:02:05 AM Last Edit: August 15, 2016, 05:03:55 AM by Egil
Larry,

After all the  work I know you have had with the compiler update, I don't like to be the devil's advocate. But....

1. After updating to v3.04, the IDE splitter control lines do not update until the lines are moved a second time. But then they move to the position choosen the first time.
    A little confusing, but appart from this, the IDE seems to works as before.

2. When showing the "About" box, the compiler version in not the same as the IDE version. In version 3.03 both IDE and Compiler reported version 3.03.


I attach screendump showing both above items.


Regards,
Egil
Support Amateur Radio  -  Have a ham  for dinner!

Andy

August 15, 2016, 05:35:19 AM #1 Last Edit: August 15, 2016, 05:37:49 AM by Andy
Egil,

Not sure about point 1, but with point 2 you are correct.

Some time ago Larry ask me if I could test out a modified version of 3.03 which I did.  This unreleased version was Larry's "half way house" version, i.e. he had fixed several things but there was more for him to do.

The official 3.03 release does say compiler version 3.03, and 3.02 states compiler version 3.02.
But it seems my test version does show 2.095, something that has been carried over into the new 3.04 release.

Firstly, I never checked the compiler stated version as I had no reason to and that was not an issue at the time.

Secondly Larry has done a lot of work on this version so I guess Larry maybe went back to a previous compiler version?

I'm sure Larry will give an explanation for it, but for myself 3.04 works and I'm happy with it.
Day after day, day after day, we struck nor breath nor motion, as idle as a painted ship upon a painted ocean.

Egil

Hi Andy,

I am sure the compiler version is the newest, and he has just forgot to update the text before compiling.
The issues above is on the version I installed on my C-drive. Usually I have both IWB  and source code on a USB-stick, but have not updated the USB version yet.

Egil

Support Amateur Radio  -  Have a ham  for dinner!

LarryMc

OK guys...
sorry for not being clear with my list of fixes in release 3.04

The 5th item in the list stated:

fixed - About dialog displayed incorrect version number for compiler

In previous versions of the  Installer's compiler I was inadvertently using the same variable to set both the version of the IDE AND the IWB Compiler to display in the About dialog.
That made it appear, in previous updates of the IDE, that the compiler was also being updated.

With this fix the version of the IDE and the version of the IWB compiler are being properly reflected.

Sorry for the confusion.
LarryMc
Larry McCaughn :)
Author of IWB+, Custom Button Designer library, Custom Chart Designer library, Snippet Manager, IWGrid control library, LM_Image control library

LarryMc

Egil
I've duplicated your problem with the splitter control.  It's a very obvious problem and I don't know how it crept in as much as I (and others) looked at this version.

I'm working on it and will issue another update ASAP.
LarryMc
Larry McCaughn :)
Author of IWB+, Custom Button Designer library, Custom Chart Designer library, Snippet Manager, IWGrid control library, LM_Image control library

Egil

The main thing is that the package now works as intended!
What I found is only cosmetic, so from now on I'll consider IWB to be female. Most women need to powder their noses every now and then.  ;D


Support Amateur Radio  -  Have a ham  for dinner!

LarryMc

I think I've got the problem fixed.  I'll do a bit of testing and hope to have a new release within the next 24 hrs.
LarryMc
Larry McCaughn :)
Author of IWB+, Custom Button Designer library, Custom Chart Designer library, Snippet Manager, IWGrid control library, LM_Image control library