May 19, 2024, 02:36:58 AM

News:

Own IWBasic 2.x ? -----> Get your free upgrade to 3.x now.........


Static Lib creation fix (Program Files folder)

Started by Andy, August 15, 2016, 12:45:53 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Andy

August 15, 2016, 12:45:53 AM Last Edit: August 15, 2016, 12:59:23 AM by Andy
Larry has done a great job in bringing version 3.04 to us.

MS in its wisdom has at some point changed the user access rights to the Program Files /
Program Files (x86) folder, however some users want to install IWB here.

Even if your user account is an admin account, when you create a folder in Program Files you are not given write permissions.  This stops you from creating a lib file as the temporary file ($$$lib.link) cannot be written to the folder.

If you want to install IWB in the Program Files folder then please follow the screenshots attached for a permanent fix, otherwise you have to run IWBDev.exe as admin everytime.

Note - After installation - close the IDE down first, also in the screenshots my user account is listed as Users (Anne-PC\Users) - Anne being my better half!

How to:
1. Go to C:\Program Files\IWBDev3 folder - right click and select "Properties" - you should see step 1 screen.

2. Click on the "Security" tab (at the top).
3. Now click the "Edit" box (in the middle).
4. Click on Users (Anne-PC\Users) (or whatever name you have).
5. Tick "Full Control".
6. Click "Apply" and "OK" and "OK" again to close the boxes down.

You now have full Read/Write permissions.

Start up IWB again and you can now (or should be able to) create lib files without any problems...

Andy.
:)


Day after day, day after day, we struck nor breath nor motion, as idle as a painted ship upon a painted ocean.

LarryMc

Andy

Did you try the "Reminder" that I posted with the release of 3.04 to see if it works with win10.  It works with win7.
LarryMc
Larry McCaughn :)
Author of IWB+, Custom Button Designer library, Custom Chart Designer library, Snippet Manager, IWGrid control library, LM_Image control library

Andy

August 15, 2016, 11:53:50 PM #2 Last Edit: August 16, 2016, 04:35:57 AM by Andy
Larry,

Yes I noted the "Reminder" section you posted on the release note.

In Win 10, running setup as admin and launching IWB straight after setup works for creating lib files, however I found that once I had closed IWB and then re-opened it as "normal" (not as admin) the creation problem persisted.

The only way I found in Windows 10 was to change the folder write permissions for the IWB sub folder within the Program Files folder.

Once I did that the problem went away.

The problem it looks to me is the creation (during a build of a lib file) of the $$$lib.link file - i.e. not being written to the folder.

It seems to be created in the same folder as the iwp project file.

I ran IWB from C:\Program Files\IWBDev3\Bin and opened my project located in a folder called c:\win10 (which I had already created) - built the lib file in that folder and there was no problem, the $$$lib.link file was in C:\win10 - to prove this I removed the full control / write permissions of the Program Files\IWBDev3 folder before I did this.

So it looks like you can install IWB in the Program Files folder, and just create lib files outside of Program Files otherwise you have to change the permissions - at least this is what I have found so far with windows 10 - I will do more testing today.

Andy.
Day after day, day after day, we struck nor breath nor motion, as idle as a painted ship upon a painted ocean.